Mordhau
 stormhawk
  • Likes received 8
  • Date joined 25 Nov '19
  • Last seen 2 Jan

Private Message

10 8
  • 2 Jan
 stormhawk

@stormhawk said:
Hello all!

Mordhau's most recent update (11/25/2019: 12:00 PM) seems to have broken Lutebot, specifically in that there is no longer a DefaultInput.ini file in Mordhau's files. That being said, there is a fix!

Credit to: Humanista, from the comments of said update, I just applied the fix to allow Lutebot to play from PageDown (he had the console set to F1).

There is a new file called Input.ini in Users > [Name] > AppData > Local > Mordhau > Saved > Config > WindowsClient

In that file, scroll to the bottom, and add these two lines of text:

[/script/engine.inputsettings]
ConsoleKey=PageDown

And voila! Done and done! Set up Lutebot as normal, just do not set the DefaultInput.ini file (not that you could anyway, since it no longer exists).

I have tested it, and it seems to work fine, but I am not entirely sure if this modification could cause you to be banned. I don't think so, since Lutebot originally did something similar, but I'm not 100% sure!

Cheers!

This is my post from a while ago, quoting it to keep it relevant for people with the same problem. Just to reiterate: you do NOT need to path Lutebot to DefaultInput.ini any more, you can safely ignore that message and follow the above quoted text.

10 8
  • 2 Jan
 stormhawk

@HYPERFREEZER said:
The final lines of my Input.ini are now
[script/engine.inputsettings]
ConsoleKey=PageDown
as suggested.
I am running LuteBot as admin. I've verified the game files, my LuteBot Console key is set to "Next" which as I understood is the PageDown key. It still keeps spamming the chat like before...

Your first line is missing a slash:
[/script/engine.inputsettings]

That might be the problem, but if it isn't then I'm not sure.

10 8
  • 2 Jan
 stormhawk

@MyersNipple said:
Is this Mod Dead?

I recently got Mordhau, and decided Lutebot sounded like fun, when I was just want to play around.

I've managed to get to appdata found my Mordhau folder, noticed theres no defaultinput folder anymore.

No problem solution I found said add script to input folder and use that. Except..Lutebot 2.0 WILL NOT accept ANYTHING other than Defaultinput.ini and refuses to even acknowledge the other files existence.

Even tried renaming the file, still no luck, so...is this Mod Dead Dead now?

It literally says ERROR Please Select the file Defaultinput.ini even when running as admin.

You do not need to path Lutebot to a file now. The fix will work, just ignore that message. Add the lines, make sure OpenConsole is set to Next, then load a file and go ingame and press play -- it should work. If it starts to spam chat, make sure your keybinds are correct.

10 8
  • 16 Dec '19
 stormhawk

@Hahero said:
I'm trying to install the bot for the first time and done everything you guys said. I editted the input file with those two lines,ran the bot as administrator and it's still not working. "Mordhau configuration file not found" is what I get. Anyone can help?

That is fine and normal! That message is outdated -- you no longer have to give Mordhau a config file. Once you've added the lines of code to Input.ini, go in game, hit play, and it should work!

Sorry for the late response! Have fun!

10 8
  • 29 Nov '19
 stormhawk

@S1NS227 said:
Well when I can't see any AppData in my pc's usernames directory

AppData is a hidden file; it cannot be opened without tweaking a few settings. Here's a helpful guide from Microsoft on how to find the right options:

https://support.microsoft.com/en-ie/help/4028316/windows-view-hidden-files-and-folders-in-windows-10

Hope this helps!

10 8
  • 1
  • 29 Nov '19
 stormhawk

@Beokles said:
My mordhau config ordner is empty.

It could be that you have the wrong Config folder; there is a Config folder located in Mordhau's Steam directory (the folder found in steamapps) which contains nothing but controller.vdf (I assume this is for playing Mordhau with a controller?). The folder you're looking for is located in AppData, a hidden folder in the root directory of your pc (the drive you boot from, normally called C:).

Here's my file pathing for Input.ini (circled in red), the greyed out area is where your pc's username would go:
Input.ini file path.PNG

However, if it's the case that you do in fact have the right config folder, then you might wanna try verifying your game files through Steam (right click Mordhau, click "Properties", click "Local Files", click "Verify Integrity of Game Files...").

If that still doesn't work, then I suggest doing a clean reinstall of Mordhau -- that is, uninstall it from Steam, then delete the Mordhau folder in Local, and the Mordhau folder in steamapps, then reinstall the game.

Let me know if this helps!

10 8
  • 1
  • 29 Nov '19
 stormhawk

@S1NS227 said:
I got in a trouble with finding this input.ini
I don't understand how to access the directory with this file

To find Input.ini, you need to go to your root directory (the drive which your computer boots from, usually called C:), and find AppData. Here's my file path to Input.ini (circled in red), the greyed out part is where your username would go: Input.ini file path.PNG

10 8
  • 26 Nov '19
 stormhawk

@ПРОРОКСАНБОЙ said:
How i can fix this? ЕБАНЫЙРОТЭТОГОКАЗИНО.png

You don't need to fix it! The current version of Mordhau no longer seems to have a "DefaultInput.ini", seemingly being replaced by Input.ini. As such, you need to add these two lines into Input.ini, at the bottom:

[/script/engine.inputsettings]
ConsoleKey=PageDown

After that, make sure the keybind for OpenConsole is set to "Next" (PageDown), and you'll be good to go! You can safely ignore that message!

10 8
  • 26 Nov '19
 stormhawk

@Alvah37 said:
doesnt seem to work for me. I'm trying to select the file and it say please select defaultinput.ini. i even renamed it to defaultinput.ini but it doesnt work

You don't need to rename Input.ini! In fact, you can ignore the message in Lutebot's settings completely! Just add those two lines into Input.ini, and set Lutebot's OpenConsole keybind to PageDown (it recognizes PageDown as "Next").

But, if you got it to work by renaming the file, I suppose that's a fix as well!

10 8
  • 25 Nov '19
 stormhawk

Hello all!

Mordhau's most recent update (11/25/2019: 12:00 PM) seems to have broken Lutebot, specifically in that there is no longer a DefaultInput.ini file in Mordhau's files. That being said, there is a fix!

Credit to: Humanista, from the comments of said update, I just applied the fix to allow Lutebot to play from PageDown (he had the console set to F1).

There is a new file called Input.ini in Users > [Name] > AppData > Local > Mordhau > Saved > Config > WindowsClient

In that file, scroll to the bottom, and add these two lines of text:

[/script/engine.inputsettings]
ConsoleKey=PageDown

And voila! Done and done! Set up Lutebot as normal, just do not set the DefaultInput.ini file (not that you could anyway, since it no longer exists).

I have tested it, and it seems to work fine, but I am not entirely sure if this modification could cause you to be banned. I don't think so, since Lutebot originally did something similar, but I'm not 100% sure!

Cheers!