Mordhau
 Brax
  • Likes received 8
  • Date joined 4 Sep
  • Last seen 24 Sep

Private Message

6 8
  • 21 Sep
 Brax

This is still happening after today's hotfix.

6 8
  • 15 Sep
 Brax

@Osi said:
Devs,

Would you kindly address this issue?

This is limiting Linux servers to Debian distributions. Is this intended? Do I need to migrate to Ubuntu server?

THANKS!

Osi,

I gave up on waiting for the devs and switched to Ubuntu, sadly. It's not as horrible to use as I remembered, but still a pain that I had to switch at all...

6 8
  • 15 Sep
 Brax

Have been seeing this error repeatedly on my servers since the latest patch.

Happens to all users.

The only fix for this is to restart the server process.

I've set up a cron script to do this automatically but even then it still can cause the server to be empty for hours at the time until I notice or a player mentions it to me. Please patch this bug ASAP.

6 8
  • 5 Sep
 Brax

After some research I've found that libcurl-gnutls is specific to Ubuntu. Most systems use libcurl's SSL TLS module, not GNU TLS.

This is severely limiting which Linux systems can host game servers, and far from a standard TLS implementation.

6 8
  • 5 Sep
 Brax

Updated OP for format.

6 8
 Brax

After the most recent update, my Mordhau server running on CentOS 7.6 will not start due to the following error:

./MordhauServer-Linux-Shipping: error while loading shared libraries: libcurl-gnutls.so.4: cannot open shared object file: No such file or directory

The libcurl-gnutls package does not exist for CentOS or any other Redhat based systems. All dependencies are installed (as the server has run fine for the past 6-12 months.)

Additionally, libcurl.i686, libcurl.x86_64. libcurl-devel.i686, and libcurl-devel.x86_64 are all installed as well.

As a workaround I even symlinked libcurl to libcurl-gnutls:

ln -s /usr/lib64/libcurl.so.4 /usr/lib64/libcurl-gnutls.so.4

This, however, just generated other errors. (And refeerences other packages which are installed (such as libstdc++))

./MordhauServer-Linux-Shipping: /lib64/libcurl-gnutls.so.4: no version information available (required by /home/mhserver/serverfiles/Mordhau/Binaries/Linux/../../Plugins/modio/Source/ThirdParty/mod.io-sdk-v0.11.3-DEV/lib/linux/x64/libmodio.so)
./MordhauServer-Linux-Shipping: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /home/mhserver/serverfiles/Mordhau/Binaries/Linux/../../Plugins/modio/Source/ThirdParty/mod.io-sdk-v0.11.3-DEV/lib/linux/x64/libmodio.so)
./MordhauServer-Linux-Shipping: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /home/mhserver/serverfiles/Mordhau/Binaries/Linux/../../Plugins/modio/Source/ThirdParty/mod.io-sdk-v0.11.3-DEV/lib/linux/x64/libmodio.so)
./MordhauServer-Linux-Shipping: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /home/mhserver/serverfiles/Mordhau/Binaries/Linux/../../Plugins/modio/Source/ThirdParty/mod.io-sdk-v0.11.3-DEV/lib/linux/x64/libmodio.so)

Please repair the server to work on Redhat derivatives as many many datacenters use this platform.

Thanks!
Brax