Mordhau
 JacktheSmack
  • Likes received 0
  • Date joined 6 Jul
  • Last seen 20 Jul

Private Message

6 0

@Gambit said:

@JacktheSmack said:
I ran open 192.168.1.11:7877 in the console with wireshark running, and no packets were sent or received from that address.

wireshark.PNG

If I click on the Internet server list in Mordhau, click Refresh with my server's name filtered, I do get a packet from it. But I cannot see it in the list.

wireshark2.PNG

Here's the packet when behind a VPN

wireshark3.PNG

I don't think you have forwarded all of the ports correctly.

I have a signature

Other people can connect fine. I had a dozen people playing last night. And port forwarding is for the barrier between the internet and the LAN, not between computers on the same LAN.

6 0

I ran open 192.168.1.11:7877 in the console with wireshark running, and no packets were sent or received from that address.

wireshark.PNG

If I click on the Internet server list in Mordhau, click Refresh with my server's name filtered, I do get a packet from it. But I cannot see it in the list.

wireshark2.PNG

Here's the packet when behind a VPN

wireshark3.PNG

6 0

So I figured out the inability to connect until after several retries. It was because Pfsense allows the same port to be forwarded to multiple devices on a network, without giving the user a warning or error in the UI. So I resolved the conflict and can now consistently connect while on VPN.

However, I still have the LAN issue. I can actually see it in the Steam Server browser if I add the server to favorites, but connecting to it just brings me to the main menu in Mordhau. The server produces no logs about any attempt to connect. It will produce a log event when I refresh the server info in the Steam server browser.

server list.png

6 0

@Gambit said:

@JacktheSmack said:
I have the following problems hosting this on my LAN:

  1. I can't see it on the server list. If I connected to a VPN, I can see it on the list. Typing open 192.168.1.11 does not do anything.
  2. When I am behind a VPN and try to connect to the server, I get the error "Failed to update server information"

All the ports are forwarded on the router. Server is Ubuntu 18 LTSB. I'm hosting an Arma 3 server just fine.

Mordhau.log

connection error.JPG!

NAT2.JPG

Are you running an Arma and Mordhau server on the same PC you play games?

No, the servers are running on a dedicated Linux box on LAN. I was able to successfully connect after multiple tries though. If I disconnect, it takes multiple tries before I get in. Load on the server is very light.

load.JPG

6 0

@JacktheSmack said:
I have the following problems hosting this on my LAN:

  1. I can't see it on the server list. If I connected to a VPN, I can see it on the list. Typing open 192.168.1.11 does not do anything.
  2. When I am behind a VPN and try to connect to the server, I get the error "Failed to update server information"

All the ports are forwarded on the router. Server is Ubuntu 18 LTSB. I'm hosting an Arma 3 server just fine.

Mordhau.log

connection error.JPG!

NAT2.JPG

Figured this out. The server name had some weird characters. When I changed it to only have letters and spaces, it worked immediately.

Name I was attempting: DCE | Horde Mode 24/7
Name that worked: DCE Horde Mode

Very strange.

Edit: Nevermind. I got the same error again. That was just a fluke. I have to try to connect to the server 5 times before it lets me in. Maybe it's requesting unopened ports that aren't forwarded on my router, and sometimes it gets an open one? Like, the range is too small. IDK

6 0

I have the following problems hosting this on my LAN:

  1. I can't see it on the server list. If I connected to a VPN, I can see it on the list. Typing open 192.168.1.11 does not do anything.
  2. When I am behind a VPN and try to connect to the server, I get the error "Failed to update server information"
    [SOLVED] pfSense had the same port forwarded to multiple devices

All the ports are forwarded on the router. Server is Ubuntu 18 LTSB. I'm hosting an Arma 3 server just fine.

Mordhau.log

connection error.JPG!

NAT2.JPG