Mordhau

Can't connect to any match and getting timed out after 15 seconds

4 3
  • 1
  • 9 Jun '19
 Oepin

I used to be able to play just fine before the new update but since I downloaded the update I'm not even able to play the game. When I press Search, it searches for a match, finds one, but before I even get to the loading screen with the mercenaries I get an error message saying "ERROR The connection has timed out". This all happens within 15-20 seconds. I'm connected to the internet through an ethernet cable btw and yesterday I plugged off the ethernet cable and switched to wifi to see if it would work, and it actually did. But today I tried the same thing it gave me the same error message it did when I had an ethernet cable plugged in. Weird. I tried a local match with bots and it worked so I'm assuming the problem lies within the connection and the network. I have tried:

-Disabling my anti-virus
-Disabling my Firewall
-Allowing Mordhau through my Firewall
-Connecting through wifi
-Changing my DNS
-Reinstalling Mordhau
-Rebooting my PC
-Rebooting Steam
-Verify integrity of local files

Edit: It works now, I guess it's solved? I didn't even do anything

Duke 554 949
  • 9 Jun '19
 Goatie

My friend is also having the same issue. He has been playing for hours and all of a sudden cannot join ANY servers after trying all these methods.

1 1
  • 9 Jun '19
 retardedlubster

I have the exact same problem, at the beginning of the patch I didn't had problems until a few hours.

Count 31 53
  • 10 Jun '19
 Jaw

Have you been able to find a work around for this problem yet or still can't stay in servers? I'm having the same issue

4 3
  • 12 Jun '19
 Oepin

Mine's ok now I didn't do anything, it magically started working again

5 2
  • 12 Jun '19
 aifka

Not for me :/

12 3
  • 15 Jun '19
 sturcot70

Can't play here either. Timed out on connects. It started yesterday. Everything was fine since launch but now game doesn't work.

5 2
  • 21 Jun '19
 aifka

Still can't play since 2 weeks...

Knight 41 35
  • 21 Jun '19
 Fürst von Butz

Marox replied in another thread and said that they identified the issue and are working on a fix.

12 3
  • 22 Jun '19
 sturcot70

Problem persists...

40 69
  • 23 Jun '19
 geach3d — Art

This problem should be fixed as of the patch of June 22nd. Please make sure you installed the patch.

3 0
  • 27 Jun '19
 DiarrheaJones

This issue is happening for me for the past 3 days.

7 2
  • 27 Jun '19
 SirA.Fortesque

Still not fixed. still waiting. a bit disappointed.

1 0
  • 27 Jun '19
 ashbosh

I just bought this game. Completed tutorial. Now i cannot join any game at all. The menu is greyed out no matter what game mode is selected. When i try and just join a server, unable to join error on any and every one i attempt to join. Wish i hadn't bought this game now. I see others are affected too.