Mordhau

LuteBot 2.0 Megathread

1 3

can anybody help me I'm currently in the early stages of setting up the lutebot where you set default input.ini, however when I go to mordhau in my steamapps there is no config just chunk layer info, engine and mordhau. any fixes or workaround wouls be appreciated
edit: it appears other new users are having this problem aswell

1 0
  • 7 Feb
 Shortstop

i cant find a file named DefaultInput.ini
i have my Mordhau file in my D drive so i searched there and could not find the file.
i also searched my C file as well and still could not find the file.
I did a whole PC search and still had no luck
what do i do?

1 0

This needs to be updated, they changed the Config. There isn't any "Steam\steamapps\common\Mordhau\Mordhau\Config\DefaultInput.ini"

There's no config file in Mordhau\Mordhau and the one that's in Mordhau\Engine only has 'controller.vdf' which is clearly not the file that they're referring to.

1 0

For some reason i dont have any ini files in my config location, or in the entire mordhau location i have no ini files
Mordhau 1.PNGMordhau 2.PNG

1 0
  • 24 Feb
 Shoroh

I found out that its possible to rename and actually convert the "controller.vdf" file to "DefaultInput.ini" (by simply renaming it, lol) and it seems to keep all data it had uncorrupted, but after I did so I was like "editing game files might be dangerous and I dont wanna get a ban" so do it at your own risk.

2 1
  • 4 Mar
 Negative

I'm having an issue with lutebot, it's correctly inputting the commands to the console, playing all the notes it should, but the console doesn't recognize the commands when they start with lowercase, i tried putting in "equipmentcommand 10" and it did nothing, then i put in "EquipmentCommand 10" and it plays the lutes note. is there a known way to fix this?

1 0
  • 5 Mar
 lowflip

cap.PNG

ive tried setting the defaultinput.ini to the input.ini because there is no more defaultinput.ini and it still doesn't work

could i get some help here?

1 0
  • 28 Mar
 Sad_Slavya

I haven't file defaultinput.ini NOWHERE on a computer. What i should to try?

8 19
  • 31 Mar
 Sninctbur

There is a fix for the DefaultInput.ini problem that a lot of people have been having.

It turns out that you don't actually need a DefaultInput.ini file; Lutebot just needs to know what your console is bound to. Go into the Key Bindings and set OpenConsole to some functionless key you never use (don't use tilde), and then go into Mordhau's key bindings, scroll all the way to the bottom, and set one of the Open Console keys to the same key.

6 6

I've reset my OpenConsole bind and the commands are being typed into the small console but the lute isn't playing. It works on the old autoconsole(big console) but I have to turn the note cooldown up too high for most of my songs to sound good or else commands will go in chat and lutebot will shit itself. Any help?

6 6

@Negative said:
I'm having an issue with lutebot, it's correctly inputting the commands to the console, playing all the notes it should, but the console doesn't recognize the commands when they start with lowercase, i tried putting in "equipmentcommand 10" and it did nothing, then i put in "EquipmentCommand 10" and it plays the lutes note. is there a known way to fix this?

Seems to be the same problem I have

Baron 5 1
  • 8 Apr
 TheLiquor

I do not have any config file for mordhau. I did a search of my entire computer for defaultinput.ini and nothing came up. help?

1 0
  • 15 Apr
 JustT

Bonjour,

J'ai essayé 4000 façons de mettre le bot mais rien à faire, il ne marche pas. Je ne trouve pas les inupts, les fichiers qu'il faut exploiter n'existent pas et je suis perdu. Les tutos sur Youtube sont obsolètes. Quelqu'un pour m'aider ?

1 0
  • 1
  • 26 Jul
 Humanista

Hello all you music lovers, and soon to be killed in battle, lets just clarify most problems with Lutebot from veterans to new players ok?

Lutebot 1.jpg

Lutebot is a legacy MIDI bot player that transforms most of your MIDI songs into console commands that reproduce the song with the lute in-game.

2 things are very important to be well configured before attempting anything in-game.


    • 1 - Your console key

Easy way to configure - In game (Settings > Key Bindings > SCROLL DOWN ALL THE WAY, LAST ROW)
Mordhau 2.jpg

Advanced way to configure - Input.ini (\Users\<user>\AppData\Local\Mordhau\Saved\Config\WindowsClient\Input.ini)
DISCLAIMER: ALWAYS MAKE A SECURE BACKUP OF ANY CONFIGURATION FILE THAT YOU ARE ABOUT TO MESS UP!
Windows 1.jpg
Windows 2.jpg
restart mordhau after .ini modification

Lutebot Configuration
(Options > Key binding)
Lutebot 2.jpg


    • 2 - Your Play key

Lutebot Configuration
(Options > Key binding)
Lutebot 3.jpg


    • Your Game needs to be in FOREGROUND when executing "PLAY"

IGNORE THE WARNING THAT SAYS "Mordhau configuration file not found. Please set the location of DefaultInput.ini in the menu above
LEgacy 1.jpg
This is a legacy message, just a reminder that "once upon a time, there was a DefaultInput.ini file"


That being said, load up your song in .MID format but do not play if your game is not in the foreground, it will breakup and attempt to type equipmentcommand <number>, due to this sequence of letters, it will end up opening your team menu, jumping and possibly causing mayhem.
If it happens, press STOP in Lutebot, press M in-game, click your team again and take control over this mess.

So first, make sure your CONSOLE opens correctly, if you first configured it and it is not working, restart mordhau and try again until it does open the console.

After that, you should know that lutebot might act up when pressing STOP or changing the song, causing the TEAM MENU issue.

If you managed to survive until here, your Lutebot might be ready to play, so hop in a server, (might be better to try this in an empty or low-player count server), select your Lute mercenary, ready it with the lute in normal mode, make sure to have your Lutebot with your playable song, press your PLAY key and enjoy.

Remember:
BARDS ARE SACRED, THEY BRING ONLY JOY AND HAPPINESS TO THE BATTLEFIELD. EACH TIME A BARD DIES, A STAR FADES AWAY IN THE NIGHT SKY.

1090 6149
  • 20 Aug
 crushed — Art

This topic has been moved.

3 0

Hi All,

The original Lutebot was broken after they released patch 14 (DefaultInput.ini was renamed and relocated).
I really wanted to use LuteBot so I made it my task to fix and improve the original application for everyone.
I found some GitHub pull requests of the original repo that included additional features and fixes by the community.
I decided to work upon those over the original build, below is a short summary of some of the changes.

  • Support for Input.ini including file location set automatically in the configuration file
  • Changed default Console Key from Page Down to the Home button
  • Setting added to set the time to zero when the play button is pressed
  • Setting added to stop notes being played when controller keys (ctrl/alt/tab) and when typing in chat
  • Various bug fixes and improvements

Download the latest release from my GitHub.

Credit goes to...
MontyLeGueux - Original Creator
ExtReMLapin - The two additional settings and various fixes and improvements

1 1

Can someone help me please? When I open the keybind menu it says i need to manually find the files, but when i get into the Mordhau files there is no "Config". What should I do? Screenshot (50).png

1 0

Is the set up for the hotfix the same?