Mordhau
Mordhau Merch
Check out our merch shop!

LuteBot 2.0 Megathread

10 8
  • 16 Dec '19
 stormhawk

@Hahero said:
I'm trying to install the bot for the first time and done everything you guys said. I editted the input file with those two lines,ran the bot as administrator and it's still not working. "Mordhau configuration file not found" is what I get. Anyone can help?

That is fine and normal! That message is outdated -- you no longer have to give Mordhau a config file. Once you've added the lines of code to Input.ini, go in game, hit play, and it should work!

Sorry for the late response! Have fun!

1 0

I fixed the problem

King 10 5
  • 19 Dec '19
 ChristmasTree

Help

My game folder does not have config folder.

C:\Program Files (x86)\Steam\steamapps\common\Mordhau\Mordhau

There are only 3 folders: Binaries, Content. Plugins

1 1
  • 1
  • 22 Dec '19
 MyersNipple

Is this Mod Dead?

I recently got Mordhau, and decided Lutebot sounded like fun, when I was just want to play around.

I've managed to get to appdata found my Mordhau folder, noticed theres no defaultinput folder anymore.

No problem solution I found said add script to input folder and use that. Except..Lutebot 2.0 WILL NOT accept ANYTHING other than Defaultinput.ini and refuses to even acknowledge the other files existence.

Even tried renaming the file, still no luck, so...is this Mod Dead Dead now?

It literally says ERROR Please Select the file Defaultinput.ini even when running as admin.

1 0
  • 28 Dec '19
 BOTJeremy

When I go into Options > Key Bindings > Mordhau Config > Mordhau Configuration Files > Set Defaultinput.ini location, The config file isn't in the Program files 86x steam steamapps common mordhau. The only files there are Binaries, Content, and Plugins. However i can find some mordhau related config file in Appdata > Local > Mordhau > Saved and its there. In the tutorial videos ive watched its not there and doesnt have the same contents. In the config file i found only CrashREportClient and WindowsClient folders were there. Also, i'm not exactly sure what it means by simply saying setdefault.ini location, like how do i do that? When i click on the config file and higlhit it, it only gives me the option to Open the config file, am i supposed to highlight it then like click apply? When i try to do that or click anywhere else, it just makes a noise and flashes the file explorer, so i have to exit it to use the desktop. Is this a common error? Ive heard that after a patch the config files were moved. Thanks, reply ASAP

2 0
  • 1
  • 31 Dec '19
 HYPERFREEZER

The final lines of my Input.ini are now
[script/engine.inputsettings]
ConsoleKey=PageDown
as suggested.
I am running LuteBot as admin. I've verified the game files, my LuteBot Console key is set to "Next" which as I understood is the PageDown key. It still keeps spamming the chat like before...

10 8
  • 2 Jan
 stormhawk

@MyersNipple said:
Is this Mod Dead?

I recently got Mordhau, and decided Lutebot sounded like fun, when I was just want to play around.

I've managed to get to appdata found my Mordhau folder, noticed theres no defaultinput folder anymore.

No problem solution I found said add script to input folder and use that. Except..Lutebot 2.0 WILL NOT accept ANYTHING other than Defaultinput.ini and refuses to even acknowledge the other files existence.

Even tried renaming the file, still no luck, so...is this Mod Dead Dead now?

It literally says ERROR Please Select the file Defaultinput.ini even when running as admin.

You do not need to path Lutebot to a file now. The fix will work, just ignore that message. Add the lines, make sure OpenConsole is set to Next, then load a file and go ingame and press play -- it should work. If it starts to spam chat, make sure your keybinds are correct.

10 8
  • 2 Jan
 stormhawk

@HYPERFREEZER said:
The final lines of my Input.ini are now
[script/engine.inputsettings]
ConsoleKey=PageDown
as suggested.
I am running LuteBot as admin. I've verified the game files, my LuteBot Console key is set to "Next" which as I understood is the PageDown key. It still keeps spamming the chat like before...

Your first line is missing a slash:
[/script/engine.inputsettings]

That might be the problem, but if it isn't then I'm not sure.

10 8
  • 2 Jan
 stormhawk

@stormhawk said:
Hello all!

Mordhau's most recent update (11/25/2019: 12:00 PM) seems to have broken Lutebot, specifically in that there is no longer a DefaultInput.ini file in Mordhau's files. That being said, there is a fix!

Credit to: Humanista, from the comments of said update, I just applied the fix to allow Lutebot to play from PageDown (he had the console set to F1).

There is a new file called Input.ini in Users > [Name] > AppData > Local > Mordhau > Saved > Config > WindowsClient

In that file, scroll to the bottom, and add these two lines of text:

[/script/engine.inputsettings]
ConsoleKey=PageDown

And voila! Done and done! Set up Lutebot as normal, just do not set the DefaultInput.ini file (not that you could anyway, since it no longer exists).

I have tested it, and it seems to work fine, but I am not entirely sure if this modification could cause you to be banned. I don't think so, since Lutebot originally did something similar, but I'm not 100% sure!

Cheers!

This is my post from a while ago, quoting it to keep it relevant for people with the same problem. Just to reiterate: you do NOT need to path Lutebot to DefaultInput.ini any more, you can safely ignore that message and follow the above quoted text.

2 0

Your first line is missing a slash:
[/script/engine.inputsettings]

That might be the problem, but if it isn't then I'm not sure.

Thanks so much, it works now!

1 0
  • 4 Jan
 Tagendorr

Don't know if it's been mentioned, sorry for repeating if it was, but if anyone is still having issues even after they set up the Lute Bot correctly just run the program as admin that fixed it on my end.

1 0
  • 4 Jan
 Susumu

It still doesn't work. I added
[/script/engine.inputsettings]
ConsoleKey=PageDown
to the Input.ini file, then run LuteBot, make sure Open Console is set on Next, then I run the game, tried to play using + on numpad, but I can only hear midi, there's no action in game.

1 0

the lutebot doesn't write the commands like "equipmentcommand 31"...

instead it misses the "i" completely. "equpmentcommand 31"

anyone know why?

1 0

Had an issue with the console bind not working.
Turns out the input.ini has a line other than the one we're supposed to add:
(it's the very last in the default list)

ConsoleKeys=Tilde

changed that to Delete and set Lutebot open console to Delete as well and now it works fine.
I'm sure it would work fine with PageDown as well, but that one's used for kick voting.

But yeah, letting people know there's another entry for opening console in input.ini and changing that fixed it for me.

1 0
  • 18 Jan
 Floza

@BOTJeremy said:
When I go into Options > Key Bindings > Mordhau Config > Mordhau Configuration Files > Set Defaultinput.ini location, The config file isn't in the Program files 86x steam steamapps common mordhau. The only files there are Binaries, Content, and Plugins. However i can find some mordhau related config file in Appdata > Local > Mordhau > Saved and its there. In the tutorial videos ive watched its not there and doesnt have the same contents. In the config file i found only CrashREportClient and WindowsClient folders were there. Also, i'm not exactly sure what it means by simply saying setdefault.ini location, like how do i do that? When i click on the config file and higlhit it, it only gives me the option to Open the config file, am i supposed to highlight it then like click apply? When i try to do that or click anywhere else, it just makes a noise and flashes the file explorer, so i have to exit it to use the desktop. Is this a common error? Ive heard that after a patch the config files were moved. Thanks, reply ASAP

Im having the exact same problem, I have no file in the Mordhau Folder names Config and there is no DefaultInput.ini Files anywhere

1 0
  • 20 Jan
 NovaX-338

@ÐMontyleGueux said:
If this is not the message you're seeing, you need to manually set the path to mordhau's configuration file. Please do so by clicking on Mordhau Config then Mordhau Configuration Files then Set DefaultInput.ini Location. Then, select the file named DefaultInput.ini in your game folder. Its default location is :
C:\Program Files (x86)\Steam\steamapps\common\Mordhau\Mordhau\Config\DefaultInput.ini
If you selected the right file, the message below should look like the picture above.

I can't find a config folder or a DefaultInput.ini file, I have all my games stored on my hard drive and the directory would be D:\Steam\steamapps\common\Mordhau\Mordhau\Config\DefaultInput.ini but the config folder doesn't exist.

2 0
  • 25 Jan
 BBGUnitater

Can someone help me please?

So I was following the instructions as given, and I saw that the keybinds said mordhau config file not found, so I tried manually inputting the file path as shown. However, the defaultinput.ini file just doesn't exist for me to begin with. I've had no issues with the game, and even after validating theres no defaultinput file. In fact, there's no config folder in Mordhau\Mordhau to begin with, so what should I do?

2 0
  • 25 Jan
 BBGUnitater

I also had another query - it says to turn off sound effects - so should the box in settings be ticked or not?

When the box is ticked, I can hear the midi file, so I'm not sure if I'm playing the song via the lute in game. When it is not ticked however, and I press the plus button, the game makes me jump and go to the team selection. I'm on the new console with cooldown of 30 so I'm not sure what to do.

1 0
  • 28 Jan
 TheAncestor

Hello, I can't find the defaultinput file even after checking the integrity of the game files so I can't configure the keybind.
Someone else is having this problem ?

2 1

Lutebot stopped responding to input, i fixed it.

1. Delete the "configuration"(it has lutebot settings) file in:
steamapps\common\Mordhau\Config.

2. Download lutebot 2.0 again and just replace all the files in
steamapps\common\Mordhau

3. go to input.ini, scroll all the way down and you should have these last lines after "axismappings"
Input.ini location: C:\Users\USERNAME\AppData\Local\Mordhau\Saved\Config\WindowsClient
(If you cant find appdata you google how to find appdata)

ControlScheme=0
AngleAttacksWithMovement=0
MouseXIsFlipAttackSide=1
InverseAttackDirectionX=0
InverseAttackDirectionY=0
AngleAttackAfterPress=1
ToggleSprint=0
ConsoleKeys=PageDown

[/script/engine.inputsettings]
ConsoleKey=PageDown

Maybe this helps someone!

YOU DO NOT set the location of defaultinput.ini in lutebot.