Mordhau

LuteBot 2.0 Megathread

3 1
  • 27 Nov '19
 GTXVII

@GTXVII said:
Can't find the DefaultInput.ini file location to set keybindings in the launcher. This may be due to the fact that the config file doesn't exist under C:\Program Files (x86)\Steam\steamapps\common\Mordhau\Mordhau. Is there a way to crate it or how do i install it?

Just saw a fix at the bottom of this thread.

3 1
  • 27 Nov '19
 GTXVII

@ZaximusRex said:

@stormhawk said:
Hello all!

Mordhau's most recent update (11/25/2019: 12:00 PM) seems to have broken Lutebot, specifically in that there is no longer a DefaultInput.ini file in Mordhau's files. That being said, there is a fix!

Credit to: Humanista, from the comments of said update, I just applied the fix to allow Lutebot to play from PageDown (he had the console set to F1).

There is a new file called Input.ini in Users > [Name] > AppData > Local > Mordhau > Saved > Config > WindowsClient

In that file, scroll to the bottom, and add these two lines of text:

[/script/engine.inputsettings]
ConsoleKey=PageDown

And voila! Done and done! Set up Lutebot as normal, just do not set the DefaultInput.ini file (not that you could anyway, since it no longer exists).

I have tested it, and it seems to work fine, but I am not entirely sure if this modification could cause you to be banned. I don't think so, since Lutebot originally did something similar, but I'm not 100% sure!

Cheers!

Thank you.

Thank you for this. this needs to be made more aware of to the bard community!

3 0
  • 28 Nov '19
 S1NS227

I got in a trouble with finding this input.ini
I don't understand how to access the directory with this file

2 0
  • 29 Nov '19
 Beokles

My mordhau config ordner is empty.

10 7
  • 1
  • 29 Nov '19
 stormhawk

@S1NS227 said:
I got in a trouble with finding this input.ini
I don't understand how to access the directory with this file

To find Input.ini, you need to go to your root directory (the drive which your computer boots from, usually called C:), and find AppData. Here's my file path to Input.ini (circled in red), the greyed out part is where your username would go: Input.ini file path.PNG

10 7
  • 1
  • 29 Nov '19
 stormhawk

@Beokles said:
My mordhau config ordner is empty.

It could be that you have the wrong Config folder; there is a Config folder located in Mordhau's Steam directory (the folder found in steamapps) which contains nothing but controller.vdf (I assume this is for playing Mordhau with a controller?). The folder you're looking for is located in AppData, a hidden folder in the root directory of your pc (the drive you boot from, normally called C:).

Here's my file pathing for Input.ini (circled in red), the greyed out area is where your pc's username would go:
Input.ini file path.PNG

However, if it's the case that you do in fact have the right config folder, then you might wanna try verifying your game files through Steam (right click Mordhau, click "Properties", click "Local Files", click "Verify Integrity of Game Files...").

If that still doesn't work, then I suggest doing a clean reinstall of Mordhau -- that is, uninstall it from Steam, then delete the Mordhau folder in Local, and the Mordhau folder in steamapps, then reinstall the game.

Let me know if this helps!

3 0
  • 29 Nov '19
 S1NS227

Well when I can't see any AppData in my pc's usernames directory

3 0
  • 29 Nov '19
 S1NS227

@S1NS227 said:
Well I can't see any AppData in my pc's usernames directory

10 7
  • 29 Nov '19
 stormhawk

@S1NS227 said:
Well when I can't see any AppData in my pc's usernames directory

AppData is a hidden file; it cannot be opened without tweaking a few settings. Here's a helpful guide from Microsoft on how to find the right options:

https://support.microsoft.com/en-ie/help/4028316/windows-view-hidden-files-and-folders-in-windows-10

Hope this helps!

1 0
  • 30 Nov '19
 M4YH3Mx

Lutebot is not saving my song profiles, everytime i open the app i need to re-do all the track filtering, is there a fix for this?

1 0
  • 3
  • 30 Nov '19
 FLG

@S1NS227 said:
Well I can't see any AppData in my pc's usernames directory

Press Windows button, write %AppData% and press enter. It Should open the directory 'Roaming' which is a subfolder of 'AppData'.

4 0
  • 2 Dec '19
 Alvah37

doesnt work for me again xD i did everything you said but when i play the song the menu only opens once
Screenshot_6.png

3 0
  • 5 Dec '19
 LuLucraft8

i cant find the defaultimput.ini. help

3 0
  • 1
  • 5 Dec '19
 LuLucraft8

i found it

3 0
  • 6 Dec '19
 LuLucraft8

@stormhawk said:

@S1NS227 said:
I got in a trouble with finding this input.ini
I don't understand how to access the directory with this file

To find Input.ini, you need to go to your root directory (the drive which your computer boots from, usually called C:), and find AppData. Here's my file path to Input.ini (circled in red), the greyed out part is where your username would go: Input.ini file path.PNG

thank you

2 0
  • 2
  • 7 Dec '19
 Razvall

thanks for info.

how i can fix problem: when i press +, in console appears random numbers 20 15 10 15 20 15 and no music.

in Input.exe i set:
[/script/engine.inputsettings]
ConsoleKey=PageDown
in LuteBot i set OpenConsole as "Next" (pagedown) button

then i load track "darud" , launch game and press + in numpad.
i didnt hear musuc, no sound, no moving. only numbers in console.

and then i see this in Input.exe:
[/Script/Engine.Console]
HistoryBuffer=++++ 16
HistoryBuffer=" 9"
HistoryBuffer=" 7"
HistoryBuffer=" 2"
HistoryBuffer=" 4"
HistoryBuffer=" 14"
HistoryBuffer=" 18"
HistoryBuffer=" 21"
HistoryBuffer=" 16"
HistoryBuffer=" 12"
HistoryBuffer=" 19"
HistoryBuffer=" 23"

how can fix it? please help

2 3
  • 8 Dec '19
 Mookie Blaylock

don't worry about the defaultinput.ini, just edit your input.ini file with those two lines at the bottom:

[/script/engine.inputsettings]
ConsoleKey=PageDown

and run lutebot as administrator otherwise you'll have errors with it.

2 0
  • 2
  • 8 Dec '19
 Razvall

i run lutebot as admin, but nothing changes.

i still see random numbers in console but didnt hear lute music in game, no animation.

why its didnt work? :(

Also, i have this message because no defaulini now.
But as i see, other users tell its ok and no need to do this step

123.jpg

this is result, i open fullscreen console to make screenshot

20191208_130146.jpg

1 0
  • 9 Dec '19
 Hahero

I'm trying to install the bot for the first time and done everything you guys said. I editted the input file with those two lines,ran the bot as administrator and it's still not working. "Mordhau configuration file not found" is what I get. Anyone can help?

1 0
  • 13 Dec '19
 Reg.42Leti

It seems to me they simply changed the filename to Input.ini. Could one of the devs check the difference between this and the DefaultInput.ini and maybe fix the value of the expected name? Would be great! :)