Mordhau

Friendly markers keybinding bug

1 6
  • 11 May '19
 AThousandD

Default friendly marker toggle key, "H", when using custom keybinds where "H" was already bound to something before the patch that introduced the friendly markers, constantly toggles friendly markers, even when the "ToggleUIMarkers" keybinding option shows empty.

Replication for this bug is 100% every time the game is run.

A solution for this bug is to clear the empty keybinds, and then open console and toggle UI markers off from there as well ("m.friendlymarkers 0").

3 1
  • 12 May '19
 MrGuarnere

Ye I have the same thing. Changed Holster to H and it kept doing both, so I removed it from being H but now I cant turn on my friend markers. Maybe we can manually change the binding in some ini or config file?

2 2
  • 12 May '19
 Sekko

I confirm this.

11 6
  • 1
  • 19 May '19
 Elgcahlxukuth

@MrGuarnere said:
Maybe we can manually change the binding in some ini or config file?

I havent tried if it works, but see this:
C:\Users\<user>\AppData\Local\Mordhau\Saved\Config\WindowsClient\Input.ini

There seem to be two alternative names for the binding, I guess that's the bug:
ActionMappings=(ActionName="Toggle UI Markers",bShift=False,bCtrl=False,bAlt=False,bCmd=False,Key=L)
ActionMappings=(ActionName="ToggleUIMarkers",bShift=False,bCtrl=False,bAlt=False,bCmd=False,Key=L)

2 1
  • 25 May '19
 Visc

LIkewise, reported this on the sticky thread just now:

Summary: Every game launch, "H" key performs ToggleUIMarkers despite being bound to something else.

Steps to reproduce:

  • Unbind ToggleUIMarkers from H.
  • bind any other action to H. (e.g. Feint)
  • Exit the game.
  • Start the game,
  • try to use H key.

Expected results:

  • action bound to H key triggers (e.g. Feint)

Actual results:

  • ToggleUIMarkers triggers

Workaround:

  • Go to keybind settings
  • hit "apply" button without changing anything.
  • From now on until next relaunch, the key works as expected but ToggleUIMarkers now does not trigger from its bound key (or any key).

-- some more investigation --

Slightly More Permanent Workaround:

  • Edit your input.ini to have "Toggle UI Markers" (as mentioned by @Elgcahlxukuth)

Bug Interpretation:

  • The game loads "Toggle UI Markers" with spaces. This is the correct format. Keys bound to "Toggle UI Markers" perform as expected. This is the format in Defaultinput.ini.
  • The game saves "ToggleUIMarkers" without spaces. This is incorrect and non-functional. Keys bound to "ToggleUIMarkers" do nothing. This is the format in Input.ini
  • When loading settings from file, if the correct "Toggle UI Markers" with spaces is absent (as it always is for me without manually editing the config file), the game binds the default "H" to "Toggle UI Markers", (via DefaultInput.ini) superceding other actions bound to H (like "use"). This is why on startup, H now toggles the markers rather than your chosen action.
  • When "apply" is clicked, the game binds your chosen action to H and your chosen markers key to "ToggleUIMarkers". Your chosen action now works, your chosen markers key now does nothing because it's bound to the wrong command, and no key triggers the markers action because nothing is bound to the correct command, "Toggle UI Markers"
30 15
  • 21 Nov '19
 Elyon

I have the same problem with "H".
Amazing to have this kind of bugs in 2019 ...