Mordhau

Stuttering and Freezing Issues

3 0

Thanks to @defman and @boosy. I did both solutions at the same time, and one (both) of them worked. Lack of lag and being able to play with sound effects really changes up the feel of the game haha

12 0
  • 30 May
 ʝℒyear87

@Boosy said:
Here is how you fix the problem, it is something to do with realtek audio cards and amd fx cpu's, if your game works with no freezing if you turn the audio off then you have this problem.
Navigate in your game files to your config, it should be here E:\Steam\steamapps\common\Mordhau\Engine\Config
Open the BaseEngine Configuration setting file
Scroll to the bottom of the file and you will see "[Messaging]
bAllowDelayedMessaging=false"
hit enter after this line twice to make sure you format correctly, and then paste this.
[/script/engine.audiosettings]
bDisableMasterEQ=True
save the file and start up mordhau, your freezing should be fixed.

Hope this helps some of you that are having stuttering and freezes.

Thank you... seriously thank you. I could not play the game until I put this into effect, now instead of freezing up and locking me to be kicked, it just drops my framerate to 20-24 fps at points where it would otherwise cause this freezing issue. wich... isn't ideal but is still better than full on freezing.

2 2
  • 2
  • 30 May
 Hlorbutan

@Boosy said:
Here is how you fix the problem, it is something to do with realtek audio cards and amd fx cpu's, if your game works with no freezing if you turn the audio off then you have this problem.
Navigate in your game files to your config, it should be here E:\Steam\steamapps\common\Mordhau\Engine\Config
Open the BaseEngine Configuration setting file
Scroll to the bottom of the file and you will see "[Messaging]
bAllowDelayedMessaging=false"
hit enter after this line twice to make sure you format correctly, and then paste this.
[/script/engine.audiosettings]
bDisableMasterEQ=True
save the file and start up mordhau, your freezing should be fixed.

Hope this helps some of you that are having stuttering and freezes.

May God grant you health, you are a kind person.
I reset everything to the initial settings, I used this advice, and now the game is just super.

3 2
 bill

Have attempted all fixes presented in this thread. Still no fixes, audio volume has no impact on performance. Any assistance is appreciated.

edit: the game seems to run fine for the first 10 minutes or so. Then it all goes to shit.

30 62
  • 2 Jun
 geach3d — Art

Hi, before trying any of these tweaks. Please try disabling cloth entirely and then lowering rag dolls to 2 for limit and duration.

3 2
  • 2 Jun
 bill

@geach3d said:
Hi, before trying any of these tweaks. Please try disabling cloth entirely and then lowering rag dolls to 2 for limit and duration.

This does not fix the problem.

30 62
  • 2 Jun
 geach3d — Art

@bill said:

@geach3d said:
Hi, before trying any of these tweaks. Please try disabling cloth entirely and then lowering rag dolls to 2 for limit and duration.

This does not fix the problem.

For many it does, which is why I ask that before fiddling around in inis and editing files, try something simple. Then delve deeper if its not fixed. Thanks

13 4
  • 2 Jun
 Evan_

@geach3d

Good evening developer fellow! Love your game, keep up the good work!

I have spent some evenings troubleshooting the spikes of low performance and crashes too. Kinda tried everything that was suggested on this forum in the past weeks (and undid them to prevent the solution-ideas from interfering).

Crashlogs always seem to point to "PhysX3_x64.dll". Here is the most recent one with 0 / 0 ragdolls on low quality and cloth physics turned off:
https://drive.google.com/open?id=12WMdNBjGjxXBbQaxuGZWj1nOUxMCu9Ds
(fresh win10 install, all drivers are updated)

I have tried various recent (and some very old) Nvidia drivers with and without their PhysX component installed. Awalys did clean installs with DDU. It didn't help.

The "-useallavailablecores" launch parameter fixed all my performance issues regardless of visual settings quality, but it still crashes every 10-20 minutes.

Setting bDisablePhysXHardwareSupport= to False in BaseEngine.ini allowed me to turn on ragdolling and cloth physics without noticeable performance impact, so I could enjoy all the lovely dismemberment. Doing so didn't seem to affect crash frequency.

(I didn't use these options to produce the above log, but the error at the end looks exactly the same when I do)

Got some more ideas what to try?

5 2

@Boosy said:
Here is how you fix the problem, it is something to do with realtek audio cards and amd fx cpu's, if your game works with no freezing if you turn the audio off then you have this problem.
Navigate in your game files to your config, it should be here E:\Steam\steamapps\common\Mordhau\Engine\Config
Open the BaseEngine Configuration setting file
Scroll to the bottom of the file and you will see "[Messaging]
bAllowDelayedMessaging=false"
hit enter after this line twice to make sure you format correctly, and then paste this.
[/script/engine.audiosettings]
bDisableMasterEQ=True
save the file and start up mordhau, your freezing should be fixed.

Hope this helps some of you that are having stuttering and freezes.

thank you so much <3
this fixed my problem

Knight 364 782
 Alphonse

I tried the above and it didn't help.

My CPU is very outdated, I know (Phenom X4 [email protected] GHz, 12 GB RAM, RX 480 8 GB, Windows 10, installed on an SSD) but the stuttering has increased after the last 2 patches. I thought hey, maybe people have unlocked more gear, so my computer is struggling with so many extra models that weren't there during the first couple days, but nope.

In FFA/Duel servers with 20-30 people I get a constant 61-62 fps / 16 ms input Still the game feels pretty sluggish, most noticeably in how fluid the camera moves, the sound stuttering, some inputs registering rather late. It even feels "wrong" while looking at the floor in the most distant corner of Tourney with no other player around.

Perhaps the devs updated the UE4 version and it's a sucky one? Idk.

So far I've tried all of the above to no success:

  • Set every ingame graphic option to low / Disabled ragdolls / Disabled Cloth

  • Disabled shadows, post processing whatever, manually (DefaultScalability.ini)

  • Disabled Steam overlay

  • Disabled antivirus and any unnecessary background processes

  • Increased Priority of both of the game's executables

  • Disabled any unused audio device in Sound settings (I have an onboard VIA audio card btw, not Realtek)

  • Updated graphic drivers. Tweaked them for "Performace".

  • Windowed, Borderless, smaller resolution, etc.

  • The forced changes to LODbias via console

  • The "DisableMasterEQ=true" thing mentioned above

1 2

Also have tried every fix here to no avail, running an I7 16gb of ram, and a gtx 1060, getting 144 frames, capped it to 60 etc, ping averaging around 30, directly connected via ethernet, still stutters, obviously the developers see this as a minority problem my friends, and will not fix it, they've been silent, they got your money, Honestly i wish the developers would just say "we're not going to fix it" silence is just unprofessional

3 2
 bill

As of Update 7 these frame drops/stutters/whatever the fuck occur twice as often now, even with all of the fixes mentioned in this thread. For fuck's sake, will someone just tell me a UE4 net_graph equivalent for diagnostics? I'd fix this myself if I knew what the fuck was causing it

Knight 364 782
 Alphonse

@Alphonse said:
I tried the above and it didn't help.

My CPU is very outdated, I know (Phenom X4 [email protected] GHz, 12 GB RAM, RX 480 8 GB, Windows 10, installed on an SSD) but the stuttering has increased after the last 2 patches. I thought hey, maybe people have unlocked more gear, so my computer is struggling with so many extra models that weren't there during the first couple days, but nope.

In FFA/Duel servers with 20-30 people I get a constant 61-62 fps / 16 ms input Still the game feels pretty sluggish, most noticeably in how fluid the camera moves, the sound stuttering, some inputs registering rather late. It even feels "wrong" while looking at the floor in the most distant corner of Tourney with no other player around.

Perhaps the devs updated the UE4 version and it's a sucky one? Idk.

So far I've tried all of the above to no success:

  • Set every ingame graphic option to low / Disabled ragdolls / Disabled Cloth

  • Disabled shadows, post processing whatever, manually (DefaultScalability.ini)

  • Disabled Steam overlay

  • Disabled antivirus and any unnecessary background processes

  • Increased Priority of both of the game's executables

  • Disabled any unused audio device in Sound settings (I have an onboard VIA audio card btw, not Realtek)

  • Updated graphic drivers. Tweaked them for "Performace".

  • Windowed, Borderless, smaller resolution, etc.

  • The forced changes to LODbias via console

  • The "DisableMasterEQ=true" thing mentioned above

Just an update. It's still happening in patch 7. It's infuriating to see my fps counter at a steady 60 fps and feel my actions are sluggish af.

  • 'stat unit' doesn't show any big fluctuation at any moment.

  • Running the game at a lower resolution (1280x720) in Windowed mode alleviates maybe 5% of the stuttering, but it's not fun playing like this at all.

  • Uninstalled the game. Deleted every config folder and file (from Program Files and AppData) before reinstalling. Still happens.

  • Disabled any unused audio devices from Device Manager.

  • Set ingame sound to 0.

I've noticed 2 things:

A session of 2 hours playing Frontline produces a log (Mordhau.log) of around 16 MB. There's a HUGE list of of Warnings of all kinds. I once heard a friend who works as a gamedev (UE) joke about how he had coded some logging events in a different thread but it was killing his harddrive by outputing a huge log. Maybe a different thread is hammering my system with useless log data? But idk. If I just join a FFA/Duel server my log is less than 500 KB after 20 or 30 minutes of play.

There's a new? process on my Task manager when Mordhau is running (UnrealCEFSubProcess.exe). It doesn't really use CPU.

Count 19 12
  • 9 Jun
 Jaw

Turning Character cloth to no cloth fixes the stuttering for me. The cloth physics don't even work most of the time when it is set to all anyway

9 3
  • 10 Jun
 Myzery

something definitely happend in patch 6, ive played 1200 hours of beta without any crashes. After patch 6 if i turn post processing or effects quality up the game will stutter and crash in under a minute, even in a empty local server.

11 2

After the latest patch the performance is getting worse. Even on lowest settings at .75 texture scaling the game is slow.
I believe it is CPU related as the performance does not change by much if I increase/decrease graphics settings.
However, my CPU is much better than the GPU - wonder if there is an optimization issue that can be looked at.

i7-8700
32gb 3200 drr4
1060 6gb
on SSD

10 0
  • 12 Jun
 qbmax

frontline is completely unplayable, performance is decreasing with each patch

this is incredibly frustrating and i really hope that the next patch has performance fixes or i might have to put mordhau down until the game is actually playable.

12 0
  • 12 Jun
 ʝℒyear87

I, completely understand that. I considered requesting a refund. but at least a majority of the issues seems to be tied to audio files, there was a file code change suggestion in here earlier that turned off something in relation to some audio effects. my game nolonger freezes and kicks me, it just drops to 20fps instead of 1. granted... that's still annoying because it messes up my reactiontimes and aim. but eh, at least its playable... still though, performance issues should be a big focus in next patch. I want to be able to play the game, I can't enjoy the new things that come out if the default unedited files of the game causes this.

9 3
  • 12 Jun
 Myzery

I take it all back i reinstalled and am getting higher frames on ultra than i was on low.

Knight 364 782
  • 1
  • 14 Jun
 Alphonse

I managed to improve the stuttering a bit. It's much more playable atm but I still get some random input laggies.

Btw, I upped my framerate from 60 to 75 and I can run a Contraband map at a constant 75 fps with 32 dummies flailing about, so again, my hardware, although outdated, works well enough.

Combination of the things that worked:

  • Cleared 98% of the files and folders I had on my Desktop. I recommend this especially if you have a bunch of image files.

  • Disabled some Adobe startup programs. Disabled BITS (Background intelligent blablabla service) which is a fucking dumb piece of software that downloads updates while you're not using your connection (but it doesn't work that way).

  • Increased Textures to High in game.

  • This had the most impact. Inside the AMD Radeon Settings software I set the "Wait for Vertical Refresh" from Enhanced VSync to OFF. It was set to "Enhanced Sync" by default and if I enable it, the game stutters like crazy.

  • Verified cache integrity (because I had tweaked some .inis).

It's still not perfect but playable for the moment.