Mordhau

Stuttering and Freezing Issues

9 0
  • 4 May
 Sulfur

@Ramsickle said:
Update: Run Mordhau, go to task manager, hit the details tab, right click on the mordhau programs, change priority to high for the cpu. The stutters stopped for me!

Did not fix it for me

1 0
 eatpants

Unfortunately this has been an issue for me in all UE4 games, but I seemed to have stumbled upon a fix. It's working in Mordhau and in Post Scriptum (UE4 shooter, based on Squad's modifications). I found this thread buried in the UE4 development forums. https://forums.unrealengine.com/unreal-engine/feedback-for-epic/1457519-4-19-4-20-editor-packaged-games-have-hangs-hiccups-constantly/page14

I know Squad was going through this with a sound driver bug affecting performance on AMD processors, and after their fix it was better but still stuttered and ate ram like crazy. Somewhere buried in that thread they talk about Nvidia Aftermath and its affect on lighting debugging? I don't really understand what it does.

specs: AMD fx-6300 4.1 oc (3+3 6core), 8gb ddr3 10600, gtx970

I tried to disable it with a console command and it was still stuttering. Then I navigated to steamapps\common\Mordhau\Engine\Binaries\ThirdParty\NVIDIA\NVaftermath\Win64 and deleted the .dll file in there. I hope someone can try this and see if it fixes the issue, because I did some other things before starting the game again.

If that doesn't work, I also went to steamapps\common\Mordhau\Mordhau\Config and deleted all the configs. Then I went to %localappdata%\Mordhau\Saved\Config\WindowsClient and deleted all the configs in there as well. I started the game and switched everything to high except Post processing & foliage(low or off), and left the 60fps cap on for the heck of it. To my surprise the game loaded into a match in 20 seconds instead of 2 full minutes, I had the usual stuttering as the textures and shaders pop in but once they all loaded I was solid 60fps with some drops into 55-58 range. Nothing like the dips into 5fps and freezes like I was getting.

Someone please try deleting that nvidia aftermath dll and see if it fixes the issue before deleting configs. I have a lower end processor but a decent video card.

9 0
  • 5 May
 Sulfur

@eatpants said:
Unfortunately this has been an issue for me in all UE4 games, but I seemed to have stumbled upon a fix. It's working in Mordhau and in Post Scriptum (UE4 shooter, based on Squad's modifications). I found this thread buried in the UE4 development forums. https://forums.unrealengine.com/unreal-engine/feedback-for-epic/1457519-4-19-4-20-editor-packaged-games-have-hangs-hiccups-constantly/page14

I know Squad was going through this with a sound driver bug affecting performance on AMD processors, and after their fix it was better but still stuttered and ate ram like crazy. Somewhere buried in that thread they talk about Nvidia Aftermath and its affect on lighting debugging? I don't really understand what it does.

specs: AMD fx-6300 4.1 oc (3+3 6core), 8gb ddr3 10600, gtx970

I tried to disable it with a console command and it was still stuttering. Then I navigated to steamapps\common\Mordhau\Engine\Binaries\ThirdParty\NVIDIA\NVaftermath\Win64 and deleted the .dll file in there. I hope someone can try this and see if it fixes the issue, because I did some other things before starting the game again.

If that doesn't work, I also went to steamapps\common\Mordhau\Mordhau\Config and deleted all the configs. Then I went to %localappdata%\Mordhau\Saved\Config\WindowsClient and deleted all the configs in there as well. I started the game and switched everything to high except Post processing & foliage(low or off), and left the 60fps cap on for the heck of it. To my surprise the game loaded into a match in 20 seconds instead of 2 full minutes, I had the usual stuttering as the textures and shaders pop in but once they all loaded I was solid 60fps with some drops into 55-58 range. Nothing like the dips into 5fps and freezes like I was getting.

Someone please try deleting that nvidia aftermath dll and see if it fixes the issue before deleting configs. I have a lower end processor but a decent video card.

Deleting the aftermath helped, but did not completely stop the stutter

12 11
 Watto

I already tried deleting the aftermath .dll but no change when i tried the extra steps I recieved this error when trying to launch the game https://gyazo.com/88666d3fef4c9f9760015ea0bbdc8f02

12 11
  • 5 May
 Watto

Here is an update videos with the suggested actions what I have done was tried deleting the aftermath.dll and ran the game with low post processing and foliage as well as no cloth. As you can see multiplayer has a huge fps drop effect to the point that i am ejected from the server. Playing the tutorial you can see the game runs much better at least at a playable standard until you the arrow kills the npc beside me. This freezing seems to always occur during an action such as swinging a sword, parrying, firing bows or riding horses. Hope this helps in narrowing down the issue.

9 0
  • 6 May
 Sulfur

@Watto said:
Here is an update videos with the suggested actions what I have done was tried deleting the aftermath.dll and ran the game with low post processing and foliage as well as no cloth. As you can see multiplayer has a huge fps drop effect to the point that i am ejected from the server. Playing the tutorial you can see the game runs much better at least at a playable standard until you the arrow kills the npc beside me. This freezing seems to always occur during an action such as swinging a sword, parrying, firing bows or riding horses. Hope this helps in narrowing down the issue.

I'm having the exact same issues. It seems whenever someone does something the game hangs up, but as long as everyone is just standing still, I can walk around at 60+ fps. It's incredibly infuriating because not only am I'm level 2 with no gold, or any experience actually playing the game, but I'm just stuck with a 30 dollar piece of non-refundable software. I just want the game to work properly.

Knight 242 1078
  • 6 May
 Corsario

@Sulfur said:

@Ramsickle said:
Update: Run Mordhau, go to task manager, hit the details tab, right click on the mordhau programs, change priority to high for the cpu. The stutters stopped for me!

Did not fix it for me

I'm also having stuttering issues after doing this. My stuttering is not as grave as the one shown in the initial post, but it ressembles a lot.

138 218
  • 6 May
 DylanS_98

Also having this issue. Wasn't happening until about a few days ago. It freezes / stutters in very specific spots.

1 1

Having the exact same issue as OP, just adding my voice so hopefully it gets more attention.

AMD FX-6300, GTX 1060

21 8
  • 7 May
 Defman

It's quite hard to play with these random 1sec freezes every 30 seconds.

AMD FX-8350, AMD R9 280X, 8GB RAM

185 205
 Roag

For those of you with nVidia cards who only recently have been having this issue please try updating to the latest driver (including hotfix)

https://nvidia.custhelp.com/app/answers/detail/a_id/4798?linkId=100000006045278

Also helpful for everyone who is replying - post your CPU and GPU model

12 11
  • 7 May
 Watto

@Roag said:
For those of you with nVidia cards who only recently have been having this issue please try updating to the latest driver (including hotfix)

https://nvidia.custhelp.com/app/answers/detail/a_id/4798?linkId=100000006045278

Also helpful for everyone who is replying - post your CPU and GPU model

Someone has already posted that hotfix and it still didn't fix the issue for me. Since I am over the two hour mark in the game I can no longer refund it. on steam. Right now I have given up what a waste of money...

1 0

Same issue here. Tried updating to latest driver now, installed the hotfix, deleted the .dll file as requested in the link you sent here, I have no bluetooth drivers so nothing to uninstall there. Given the game high priority in task manager, first tested on a HDD and then on a SSD.

GPU: EVGA GeForce GTX 1070 FTW Gaming
CPU: Intel Core i7-7700K Kaby Lake

I experience the stuttering, but also the game takes its time loading assets properly to get good quality, because part of the ground and armor can be blurry until it has loaded properly. I am not talking minutes, but there are a few seconds, and it shouldn't be like this. Also loading in this game takes a while.
After installing on SSD, the loading is a lot better, same for the assets loading, but stuttering is the same.

Seems poorly optimized in my eyes.
I have spent 70 minutes of gametime testing after doing troubleshooting, so we are closing in on the refund here if I can't get this fixed.

2 2
  • 7 May
 Hlorbutan

NVIDIA GeForce GTX 960
AMD FX8350
16 GB RAM

The same problem as the author of the topic, freezes and disconnects from the server.

1 0
  • 7 May
 WARCULT

Somewhat same issues here aswell. I crash/freeze to the point of having to close the game in task manager at the start of every match in the team select screen. I ran the game for a few days with little to no crashes and it started happening yesterday.
Ive reinstalled the game and verified the game files.. Frustrating but hopefully i can get this fixed somehow.

3 6
  • 7 May
 Strigon1

Another with the micro stutter issue... and AMD
Fx 8350 / AMD fury x . I get 60 FPS then every 25-30 seconds or so it will get a 1-2 second freeze frame. Makes the game unplayable as you get killed if you are anywhere close to an enemy.
Tried to set task priority as high, deleted nvidia dll etc. and no change. Moved game to ssd from hdd - no change. Seems like an issue with this cpu and game. Would much rather have stable 30 FPS than this... hope devs can isolate the issue

21 8
  • 8 May
 Defman

IIRC I didn't have these problems on Public Build #1, though I've only played Horde at that time.

2 0
  • 8 May
 EOKA

The same problem as the author of the topic, freezes and disconnects from the server.

9 0
  • 8 May
 Sulfur

Still having issues after todays patch as well.

3 6
  • 9 May
 Strigon1

OK BOYS I finally found a fix that works for me (AMD CPU)
For me personally, the issue was/is completely related to audio. You will know very quickly if your freezing problem is audio related if you lower EFFECTS VOLUME to 0 in the in game settings menu. This was a temporary fix for me but obviously nobody wants to play the game on mute.

  1. Disable any audio drivers you aren't using in device manager
  2. Make sure you are using surround 7.1 speaker. For example I have realtekHD and it was set to stereo for some reason instead of 7.1.