Mordhau
Mordhau Merch
Check out our merch shop!

How to run a dedicated server (Windows)

Count 256 281

@隊友都垃圾很可憐 said:
Can you tell me how to make the respawn time of all modes consistent?

Here is the settings for changing respawn times in the server Game.ini

[/Script/Mordhau.MordhauGameMode]
PlayerRespawnTime=5
BallistaRespawnTime=300.000000
CatapultRespawnTime=300.000000
HorseRespawnTime=300.000000

Count 256 281

@隊友都垃圾很可憐 said:
Can you tell me how to make the respawn time of all modes consistent?

You can do by editing the following player option in the UDKGame.ini
[/Script/Mordhau.MordhauGameMode]
PlayerRespawnTime=7.000000
AutoKickOnTeamKillAmount=5
BallistaRespawnTime=300.000000
CatapultRespawnTime=300.000000
HorseRespawnTime=300.000000

1 0
  • 6 Jan
 Sempiro

Hello,

Have created the server and people can connect, but I have some issues:

  1. DefaultGame.ini nowhere to be found, hence I cannot change the default map.
  2. After starting the server, no matter what config I use it starts from Pit and I need to change the map manually through the console.

Any workaround? How to change default map?

Thanks in advance

Count 256 281

@Sempiro said:
Hello,

Have created the server and people can connect, but I have some issues:

  1. DefaultGame.ini nowhere to be found, hence I cannot change the default map.
  2. After starting the server, no matter what config I use it starts from Pit and I need to change the map manually through the console.

Any workaround? How to change default map?

Thanks in advance

So you do not want DefaultGame.ini that is the wrong file and the wrong location. Depending on where you installed the game you are looking for C:......Mordhau/saved/config/WindowsServer and then Game.ini

You can change the default map in the game.ini as well as the maplist into the type of server you want to run. This maybe different if you rented a server. Some server host have it where you can change the default starting map in the command line.

2 0
  • 6 Mar
 o0Julia0o

Can you host a Server with bots in it? So 3 players can paly versus some bots?

Count 256 281

@o0Julia0o said:
Can you host a Server with bots in it? So 3 players can paly versus some bots?

I believe you have put "addbots 3" into the command line, if not try the Game.ini as well

874 375

Or just don't run a Windows server. Who would do sucha thing?

Count 256 281

Hey if anyone is interested in having custom graphics with clickable links on your server's MOTD. Let me know. I have reasonable design fees and can even host the html file if you need it. PM me on Discord. Here is an example for what I did for our server. http://rhinoceg.com/orangebox/kila/mmotd.html

1 0
  • 1
  • 20 May
 wutyfy

Hi, topic is quite old but i hope there's somebody to help. First for some reason "restartlevel" command doesn't work for me, i've tested if admin commands works at all and they do, the only one i can't get to work is restarting a map. Second thing is it possible to delay hp regeneration or even turn it off? I'll be grateful for any help, cheers!

3 0
  • 27 Aug
 FullyLegend

I've did everything, when I try to login as admin nothing happens, I've tried changing the password, anyone here to help?

3 0
  • 27 Aug
 FullyLegend

@FullyLegend said:
I've did everything, when I try to login as admin nothing happens, I've tried changing the password, anyone here to help?

Not only that, I can't find my server at all.

3 0
  • 27 Aug
 FullyLegend

@FullyLegend said:

@FullyLegend said:
I've did everything, when I try to login as admin nothing happens, I've tried changing the password, anyone here to help?

Not only that, I can't find my server at all.

Turns out my server wasn't on, because for some reason it errors when it loads The Pit, anyone knows a fix? I don't even have The Pit in map rotation

35 18
 Aleihric

Hey, I was wondering if anyone else is having troubles getting edits to the server script to stick?

It used to be I could jostle the maps around in the rotation list without a problem, and they would always stick after saving. Now it doesn't seem to register anymore.

I would very much appreciate it if someone were to help me.

Edit: Solved. I reinstalled the server.

1 0
  • 6 Oct
 Rigatoni

So I tried this myself however I have Google Wifi with an extender of some sort, and it just doesn’t work. I put in all of the ports and set it to UDP and my computer will still register the ports as closed, any idea why?

Knight 2307 4188
  • 15 Oct
 lazy
This comment was deleted.